Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8154 closed bug (duplicate)

load() is not working in jquery 1.5.

Reported by: anonymous Owned by: anonymous
Priority: high Milestone: 1.next
Component: ajax Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Try this simple line. it works in 1.4.4 but not in 1.5. $('body').load('test.html');

Change History (6)

comment:1 Changed 9 years ago by jitter

Component: unfiledajax
Owner: set to anonymous
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Your bug report doesn't contain enough information to give a hint on what you are doing. I made this test case which works as expected.

So please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.

Also note that there were some bugs with loading "local" (file:///) files in 1.5, which have been fixed, so please also try with the current jQuery WIP version as described in the link below.


How to report bugs

comment:2 Changed 9 years ago by anonymous

Status: pendingnew

I'm loading a local file, i can't put it on jsfiddle. Other people are also experiencing the same issue. check http://stackoverflow.com/questions/4882774/jquery-1-5-load-not-working.

Just try to load a local file in 1.5 using $('body').load('test.html'); and you will see it's not working.

comment:3 Changed 9 years ago by anonymous

btw, i'm linking from http://ajax.aspnetcdn.com/ajax/jQuery/jquery-1.5.min.js. Assuming they have the very latest.

comment:4 Changed 9 years ago by anonymous

Linking from http://code.jquery.com/jquery-git.js works. So i'm assuming you fixed this issue. But How can i link to the latest jquery release from from google or Microsoft cdn. When will they receive the latest update.

comment:5 Changed 9 years ago by jitter

Priority: lowhigh
Resolution: duplicate
Status: newclosed

Thanks for reporting back and providing more information. This was indeed already reported and fixed in jquery-git. As soon as jQuery 1.5.1 comes out you will be able to link to it via CDN.

comment:6 Changed 9 years ago by jitter

Duplicate of #8125.

Note: See TracTickets for help on using tickets.