Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#8143 closed bug (invalid)

aria-selected setting/unsetting behaves unusually

Reported by: wheresrhys@… Owned by: wheresrhys@…
Priority: low Milestone: 1.next
Component: attributes Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

The following code

li.removeAttr("aria-selected").eq(myInteger).attr("aria-selected", "true");

works as expected. However

li.attr("aria-selected", "").eq(myInteger).attr("aria-selected", "true");

won't set the value to true on the second time it's called

Change History (2)

comment:1 Changed 8 years ago by jitter

Component: unfiledattributes
Owner: set to wheresrhys@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Also make sure to read the link given below, in order to provide a most useful bug report.


How to report bugs

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.