Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8141 closed bug (duplicate)

appendTo appends given HTML twice when used in document.onready

Reported by: mduerksen Owned by: rwaldron
Priority: high Milestone: 1.5.1
Component: event Version: 1.5
Keywords: Cc:
Blocked by: #8145 Blocking:

Description

This only happens when using document.onready. With $(document).ready() everything is fine. Also, this only happens with v1.5, v1.4.4 works even with document.onready.

Example: http://jsfiddle.net/ehynds/yuMTH/

OS: Win7 Tested Browsers: IE8, FF 3.6.13

Change History (5)

comment:1 Changed 6 years ago by mduerksen

comment:2 Changed 6 years ago by dmethvin

  • Component changed from unfiled to event
  • Milestone changed from 1.next to 1.5.1
  • Owner set to dmethvin
  • Priority changed from undecided to low
  • Status changed from new to assigned

We've never supported a document.onready property, so this usage is invalid. However I'll look into it and see why it is firing at all.

To reiterate, document.onready is not valid usage and we do not intend to support it, so do not expect it to work.

comment:3 Changed 6 years ago by rwaldron

  • Blocked by 8145 added
  • Owner changed from dmethvin to rwaldron
  • Priority changed from low to high

comment:4 Changed 6 years ago by rwaldron

  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:5 Changed 6 years ago by rwaldron

Duplicate of #8522.

Note: See TracTickets for help on using tickets.