Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8086 closed bug (duplicate)

Firefox: can't insert form inside form with html - but with append

Reported by: dwt Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I've noticed that Firefox can't insert a form inside a p inside another form with .htm(). The same works fine with html().append(...)

Debugging this seems as if Firefox just silently ignores the this[i].innerHTML = value in html() - nut sure whats up there.

Reduction appended

Change History (7)

comment:1 Changed 8 years ago by dwt

Uhm, I mean on jsFiddle http://jsfiddle.net/BMzct/

comment:2 Changed 8 years ago by dwt

and annotated it with the workaround

comment:3 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:4 Changed 8 years ago by Rick Waldron

Duplicate of #6894.

comment:5 Changed 8 years ago by dwt

I disagree, the problem is that the form is not inserted, not that it can't be selected.

comment:6 Changed 8 years ago by jitter

The answer on the ticket linked to above applies also to this report.

nested forms are invalid and the browser isn't obligated to do anything predictable with invalid html

comment:7 Changed 8 years ago by Rick Waldron

#9416 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.