Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#8051 closed bug (duplicate)

col .width() of a colgroup returns 0

Reported by: TiTi Owned by:
Priority: low Milestone: 1.next
Component: dimensions Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

The .width() method returns 0 on a <col> element for Google Chrome current stable release (8.0.552.237), and also IE9 and Safari.

Doh in fact it only works on Firefox....

Test: http://jsfiddle.net/NeTS5/

Workaround I'm using for thoses interested: get the corresponding <th> width, or a visible cell for that column...

Change History (2)

comment:1 Changed 9 years ago by jitter

Component: unfileddimensions
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a test case!

This isn't a bug as the col element itself doesn't have a width. It's just used to style the real columns of a table.

See also these tickets #7913, #7782 for more information

comment:2 Changed 9 years ago by jitter

Duplicate of #7782.

Note: See TracTickets for help on using tickets.