Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8042 closed bug (duplicate)

jQuery.data() should have better behavior when int overflows

Reported by: embrangler Owned by:
Priority: high Milestone: 1.5
Component: data Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

When calling jQuery.data() on DOM attrs containing large integers, the result could be:

  1. a string (seems most convenient)
  2. undefined, NaN, etc.

At the very least, it shouldn't return something different from the string attr itself and pretend that it's returning what you expect.

Example: http://jsfiddle.net/GnJJS/1/

Change History (2)

comment:1 Changed 11 years ago by jitter

Component: unfileddata
Milestone: 1.next1.5
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by jitter

Duplicate of #7579.

Note: See TracTickets for help on using tickets.