Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#8037 closed bug (worksforme)

fadeToggle() & bugs in IE (all versions) with PNG, MNG, APNG

Reported by: monolithed@… Owned by: monolithed@…
Priority: low Milestone: 1.next
Component: effects Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

fadeToggle() bug with alpha-channel in IE (all versions) with PNG, MNG, APNG

examle: http://www.jsfiddle.net/APZ4h/3/

Change History (4)

comment:1 Changed 7 years ago by addyosmani

Owner: set to monolithed@…
Priority: undecidedlow
Status: newpending

Tested this with IE6 and there didn't appear to be any problems at all. With IE8 and IE9 there's a minor difference in how the graphics are faded out but this seems to be more to do with IE's PNG/transparent image handling than anything else.

Could you go into detail about what the bug you're experiencing?

comment:2 Changed 7 years ago by monlithed

Could you go into detail about what the bug you're experiencing?

Platform: Windows XP SP3

watch the video:

http://www.jsfiddle.net/APZ4h/5/

comment:3 Changed 7 years ago by jitter

Component: unfiledeffects

I guess this one of the many IE png transparency bugs. What workarounds to that did you try out?

Version 0, edited 7 years ago by jitter (next)

comment:4 Changed 7 years ago by jitter

Resolution: worksforme
Status: pendingclosed

This test case doesn't have the behavior shown in your video anymore for me. Fixing this was as easy as setting a background color on the image elements, which is a known workaround for some IE png issue and one of the first hints you get when googling.

Note: See TracTickets for help on using tickets.