Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8031 closed bug (invalid)

height calculation hidden element bug cause slidedown jump

Reported by: sabithpocker@… Owned by: sabithpocker@…
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

960px wrapper. div to be animated has no width and is inside 200px column with position 'static'. slide down calculates width by making position of div 'absolute', but then it inherits width of wrapper960(position:relative) instead of parent 200px column(static). This results in wrong height calculation. height calculation is guessed to be following: make position of elemnt absolute make its visibility hidden make its display normal. now take the height. guess of solution: make position of elemnt absolute make parent position relative? make its visibility hidden make its display normal. now take the height.

Change History (3)

comment:1 Changed 9 years ago by jitter

Owner: set to sabithpocker@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.


How to report bugs

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 9 years ago by cameron@…

I'm not the original reporter, but I think I'm experiencing the same problem.

http://jsfiddle.net/XQzMU/2/

Note how it jumps at the end. Setting position: relative on #container fixes it.

Note: See TracTickets for help on using tickets.