Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#8030 closed bug (invalid)

slideToggle callback does fire before Animation is complete

Reported by: thierry.nicola@… Owned by: thierry.nicola@…
Priority: low Milestone: 1.next
Component: effects Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

SlideToggle callback fires callback function before animation is complete. I used duration 0 as a work around, but I have found no other solution than postingthis issue here

Change History (6)

comment:1 Changed 8 years ago by jitter

Component: unfiledeffects
Priority: undecidedlow

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.

Also make sure to test with the current jQuery version and the jQuery WIP version.


How to report bugs

comment:2 Changed 8 years ago by jitter

Owner: set to thierry.nicola@…
Status: newpending

comment:3 Changed 8 years ago by jitter

This quick test case doesn't seem to suffer from the issue described.

comment:4 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:5 Changed 7 years ago by anonymous

I've also seen this bug in action, http://jsfiddle.net/P2DUM/12/

basically, if you put a function call into the callback, instead of a function, then the callback looks to fire immediately.

comment:6 Changed 5 years ago by anonymous

I experienced the same issue if I have a slideToggle in an ajax callback it fires immediately instead of on finish

Note: See TracTickets for help on using tickets.