Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8011 closed bug (worksforme)

Complete handler not called when any XMLHttpRequest is aborted

Reported by: contact.indian@… Owned by: contact.indian@…
Priority: low Milestone: 1.next
Component: ajax Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

I wanted to reopen the below ticket, but didn't see any option to reopen. So creating a new one.

http://bugs.jquery.com/ticket/5114

The bug is again introduced in jQuery version 1.4.4

If I abort any XMLHttpRequest, the complete handler is not being called.

Change History (5)

comment:1 Changed 9 years ago by addyosmani

Owner: set to contact.indian@…
Status: newpending

Thanks for submitting a ticket to the jQuery Bug Tracker!. Please provide a reduced jsFiddle.net test case that reproduces the issue you mention you're still seeing in 1.4.4 so that we can confirm whether this is just an issue with the code you are testing or an issue with jQuery core.

comment:2 Changed 9 years ago by danheberden

Resolution: invalid
Status: pendingclosed

Bug not present / fixed with new ajax rewrite. Get ready for 1.5, its gonna be hawt!

http://jsfiddle.net/danheberden/ANfCQ/

comment:3 Changed 9 years ago by jitter

Component: unfiledajax
Priority: undecidedlow

I also couldn't reproduce this issue neither with 1.4.4 nor with 1.5b1 (which includes a major ajax rewrite), tested Opera 11, FF 4b7, Chrome 8, IE8

This test case works fine for me both error and complete callback get called.

Please report back and request the reopening of this ticket if you can provide a reduced test case which reproduces your problem on http://jsfiddle.net with the current version of jQuery.


How to report bugs

comment:4 Changed 9 years ago by jitter

Resolution: invalid
Status: closedreopened

comment:5 Changed 9 years ago by jitter

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.