Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8010 closed bug (duplicate)

appendTo does not work in IE8 on an empty popup

Reported by: TiTi Owned by:
Priority: low Milestone: 1.next
Component: manipulation Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hello, It seems I'm unable to append elements in IE8 (works on FF & Chrome & Opera) on an empty popup opened with window.open().

Demo: http://jsfiddle.net/kxbur/

Note: Do NOT close the popup before closing the alert()

Error is "no such interface support": fragment.appendChild( ret[i] );

Change History (4)

comment:1 Changed 9 years ago by TiTi

Bug documentation and solution here:

http://tamentis.com/doc/no_such_interface/

Seems jQuery isn't part - for now - of the group mentionned : "Most JS framework already have a solution to this issue" :p

comment:2 Changed 9 years ago by TiTi

The link I previously mentionned is correct: "The solution to this issue is to create all the elements AND EVENTS using the new window and not the original one". Their example is not as clear as it could be however...

.appendTo() works great if you pass a DOM element created with the new window. But fail if created from original window (html string or created with $() just before).

Enhanced demo & workaround: http://jsfiddle.net/yfWzR/1/

comment:3 Changed 9 years ago by jitter

Component: unfiledmanipulation
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a test case!

This is a known issue you can follow the ticket below for progress on this.

comment:4 Changed 9 years ago by jitter

Duplicate of #4059.

Note: See TracTickets for help on using tickets.