Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8004 closed bug (duplicate)

focusout not triggered when focus()ing another input

Reported by: [email protected] Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

jquery 1.4.3+ has different (i believe broken) behavior for detecting focus() triggers and issuing focusout events. they do not appear to be triggered on the previously focused input at all when calling focus() on a new input.

when setting focus non-programatically it works okay i think.

discussion, observations, sample code and logs here: https://forum.jquery.com/topic/v1-4-3-unexpected-focus-behavior

1.4.3+ in chrome the results are also different, the log shows not only duplicated events, but are inconsistent with FF results for the same version.

the only consistency and reasonable behavior i have found is in v1.4.2.

tested in FF3.6 stable FF4 nightly, chrome daily.

thanks, Leon

Change History (2)

comment:1 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by dmethvin

Duplicate of #7340.

Note: See TracTickets for help on using tickets.