Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8003 closed bug (duplicate)

Child selector followed by ancestor selector not working in IE

Reported by: jacob.h.page@… Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Given the following HTML and JavaScript:

    <html>
      <head>
        <script type="text/javascript" src="jquery.min.js"></script>
        <script type="text/javascript">
          $(document).ready(function() {
            $('.a > div a').text("Found!");
          });
        </script>
      </head>
      <body>
        <div class="a">
          <div>
            <a href="#">Not Found</a>
            <div>
              <a href="#">Not Found</a>
            </div>
          </div>
        </div>
      </body>
    </html>

I would expect that both hyperlinks' text would change. In Chrome and Firefox, they do, but in IE 8 at least, only the first hyperlink changes. It appears as though ancestor selectors do not work properly after a child selector has been encountered.

Change History (2)

comment:1 Changed 9 years ago by jitter

Component: unfiledselector
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a test case!

I identified this to be a known issue. Check the ticket mentioned below for progress on this issue.

comment:2 Changed 9 years ago by jitter

Duplicate of #4344.

Note: See TracTickets for help on using tickets.