Bug Tracker

Opened 16 years ago

Closed 16 years ago

#80 closed bug (fixed)

'f has no properties' when using parents(...)

Reported by: anonymous Owned by:
Priority: critical Milestone: 1.0
Component: core Version: 1.0
Keywords: Cc:
Blocked by: Blocking:

Description

Using svn jquery, testcase is here: http://fuzz.bassistance.de/jQueryFormValidation/parentsBug.html Problem occurs in both FF1.5 and IE6.

My research of the problem is this: In line 873 (var t = axis[i];), undefined is assigned to t. Why that? The assignments in axis for parents and ancestors both refer to jQuery.parents. jQuery.parents on the other hand is defined somewhere later. I did a quick test and defined that function directly in the axis object, that works. Seems to be a 'reference to a not yet defined element' problem. I tried changing the reference to a string, but that causes other errors...

Change History (4)

comment:1 Changed 16 years ago by john

Component: ajaxcore
Milestone: 1.0
Version: 1.0

comment:2 Changed 16 years ago by anonymous

Priority: majorcritical

comment:3 Changed 16 years ago by brice

I confirm this problem. It effects sibling and ancestor functions. I get the 'f has no properties' error when using the following code;

$("form .validate").each(function(i) {

var x = $(this).parents(); error is thrown debugger;

...

jQ Version: SVN Rev 162

~ Brice

comment:4 Changed 16 years ago by john

Resolution: fixed
Status: newclosed

Fixed in SVN rev 163.

Note: See TracTickets for help on using tickets.