Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7971 closed enhancement (duplicate)

load() shouldn't add already referenced scripts

Reported by: [email protected] Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Suppose the following scenario:

  • "document a" contains a reference to jquery, and a jquery plugin.
  • "document b" contains a reference to jquery only
  • "document a" loads "document b" via the load() method.

Now, the jquery instance of "document a" has been overwritten by the "document b"'s version, and the plugin loaded before on document a is not available anymore in the jquery object.

I'm not sure if this behavior is applicable to every javascript out there, but it could be nice if we could check if a reference already exists in the main document when adding the new javascript via the load() method.

Change History (2)

comment:1 Changed 11 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:2 Changed 11 years ago by Rick Waldron

Duplicate of #7757.

Note: See TracTickets for help on using tickets.