Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7970 closed bug (worksforme)

Ajax on Windows Mobile don't work (having fix)

Reported by: info@… Owned by: info@…
Priority: low Milestone: 1.next
Component: ajax Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

There is old bug from jQuery 1.2 version. This bug have known fix: http://community.livejournal.com/ru_webdev/2638679.html (in Russian)

Change History (3)

comment:1 Changed 9 years ago by jitter

Component: unfiledajax
Owner: set to info@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.

If I understood correctly you reported this against jQuery 1.2? That is a very old version so please verify if this still applies to today released 1.5b1 version of jQuery.


How to report bugs

comment:2 Changed 9 years ago by info@…

Status: pendingnew

I have this problem with jQuery 1.4.4 shipped with Microsoft MVC3 package. Mobile device is HTC TyTN WM6.

I'm use google to search information and find this post with workaround.

Here is my code:

<!DOCTYPE html>
<html lang="en" dir="ltr">
<head>
  <meta http-equiv="content-type" content="text/html;charset=UTF-8" />
  <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />
  <title>Write to Us!</title>
  <link href="/Content/Site.css" rel="stylesheet" type="text/css" media="all, handheld, print, screen" />
  <link href="/Scripts/themes/ui-lightness-rem/jquery-ui.css" rel="stylesheet" type="text/css" media="all" />
  <script src="/Scripts/jquery-1.4.4.min.js" type="text/javascript"></script>

  <script src="/Scripts/jquery-ui.min.js" type="text/javascript"></script>
  <script src="/Scripts/jquery-ui-i18n.js" type="text/javascript"></script>
</head>
<body>
  <div id="page">
  <div id="logindisplay">
    <script language="JavaScript" type="text/javascript">
      $(function () { $('#logindisplay').load('/en/Account/RenderLoginForm'); });
    </script>
    Loading...
  </div>
  </div>
</body>
</html>

This code works nice in desktop FF, IE8, Chrome. /en/Account/RenderLoginForm - return html block with login form or user information if logged. In Windows Mobile 6 devices (my HTC TyTN and some other tested) displayed "Loading..."

comment:3 Changed 9 years ago by jitter

Resolution: worksforme
Status: newclosed

The "fix" mentioned on the website you linked to is in jQuery since 1.4.0. I also couldn't reproduce your problem with this test case and the Windows Mobile 6.1.4 Emulator

If you can provide a reduced test on http://jsfiddle.net which reproduces the problem, report back and so we can investigate the issue further. Also include more specific information (MVC3 package final release?, useragent string of the browser, ...)


P.S.: I couldn't find any useful information on msdn blog site the russian site links to.

P.P.S.: The new ActiveXObject("MSXML2.XMLHTTP"); line should only be needed for IE <= 5 (which is not supported).

Note: See TracTickets for help on using tickets.