Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#7960 closed bug (worksforme)

[support.mozilla.com] jQuery slide()/slideToggle() partly animates and then hides, sometime after 1.4.1

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: 1.next
Component: effects Version: 1.4.4
Keywords: needsreview Cc:
Blocked by: Blocking:

Description

So we recently updated jQuery from 1.4.2 to 1.4.4 and the slideToggle events we use have regressed.

See a demo here [1]. Click on the headings of the sections, e.g. "Übersicht". Happens in Firefox 3.6 and Firefox 4, at least, maybe others as well.

I have tested that downgrading to 1.4.2 does not reproduce the issue, so it's something in jQuery core, I suspect.

[1] support.mozilla.com/de/localization

Change History (4)

comment:1 Changed 11 years ago by jitter

Component: unfiledeffects
Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Could you please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further. Because the mozilla localization page you linked to contains too much code and only minified javascript which makes it very hard to pin-point where the problem might be.

comment:2 Changed 11 years ago by [email protected]

Status: pendingnew

So we figured out why it was happening for us. We're going to fix it by not using display: table.

My coworker Ricky figured this all out and came up with a simple example here: http://jsfiddle.net/znQSv/

Looks like this regressed between 1.4.3 and 1.4.4, you'll notice that if you switch between them. There is still some wonkiness going on, and sadly the most recent version that is working perfectly fine seems to be 1.2.6!

Hope this helps!

comment:3 Changed 11 years ago by Rick Waldron

Keywords: needsreview added
Resolution: worksforme
Status: newclosed

Closing per reporters findings

comment:4 Changed 11 years ago by [email protected]

I'm not sure why this was closed. It is still a bug with slide animation for display: table

Note: See TracTickets for help on using tickets.