Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7949 closed bug (invalid)

Type Error thrown in IE8 - related to querySelectorAll

Reported by: gray8110@… Owned by: gray8110@…
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

I haven't been able to pinpoint what is causing an object to be passed to the replace method, but when running a minified version of 1.4.4, but this line within the qSA declaration will throw a type error in IE8. Older versions of IE and webkit/mozilla browsers

query = query.replace(/\=\s*([^'"\]]*)\s*\]/g, "='$1']");

I've been able to resolve the issue by checking that query is a string before invoking replace(). This error is only reproducible when jQuery has been minified. The error is thrown using both YUI and closure compiler minified code including the OOTB version provided by jQuery.

Change History (3)

comment:1 Changed 9 years ago by gray8110@…

Just a clarification - Older versions of IE and webkit/mozilla browsers do not throw the error.

comment:2 Changed 9 years ago by addyosmani

Owner: set to gray8110@…
Status: newpending

Thanks for submitting a ticket to the jQuery Bug Tracker. In order for us to fully evaluate the bug you are experiencing, please provide us a reduced test case (ideally on http://jsfiddle.net.

Are you saying that you're experiencing the error in IE8 by simply including jQuery 1.4.4 in minified form in your pages? Again, as much information as possible would help greatly here.

comment:3 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.