Bug Tracker

Opened 9 years ago

Closed 8 years ago

#7919 closed bug (invalid)

$.get behaves differently in i.e and firefox

Reported by: ealkilicgil@… Owned by: ealkilicgil@…
Priority: undecided Milestone: 1.next
Component: ajax Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

i've used jquery $.get in my mvc application. I hava a list displaying hotels. I update the hotel by using Jquery UI dialog. I fill the dialog using $.get to a partial view(hotel details). When user edit the details and saves the page, the updated hotel is listed in the list correctly. But if the user selects the updated hotel again from the list, then unupdated version of the hotel is displayed in i.e. but in firefox updated version is displayed. I think in the first get request i.e. caches my partial view.

Change History (2)

comment:1 Changed 9 years ago by jitter

Component: unfiledajax
Owner: set to ealkilicgil@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.

You might want to try and use $.ajax directly, instead of the $.get convenience function, and set the cache option to false.


How to report bugs

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.