Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#7872 closed bug (invalid)

Uncaught TypeError: Object #<an Object> has no method 'replace'

Reported by: Cogito Owned by: Cogito
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

When using jScrollPane plugin in combination with Jquery-1.4.4. we got an error when we use the plugin like this:

<div class="scroll-paneHolder"> <div class="scroll-pane"> <table >

<tr>

<td>

<img src="../../gfx/a2info_.gif" alt="" />

</td> <td>

<span class="thickbox">1 x Philips 19pfl3605/12 Led tv</span><br /> <span class="priceTag">249.-</span>

</td>

</tr>

</table> </div> </div>

Error: Uncaught TypeError: Object #<an Object> has no method 'replace' (jquery-1.4.4.min.js:4085)

When we rollback to version 1.4.3. there are no problems. Comparing those different versions, I can see that line 4085 is introduced since 1.4.4: query = query.replace(/\=\s*(['"\]]*)\s*\]/g, "='$1']");

Callstack: Sizzle jquery-1.4.4.min.js:4085 jQuery.fn.extend.find jquery-1.4.4.min.js:4340 B jquery.jscrollpane.min.js:614 an jquery.jscrollpane.min.js:106 d jquery.jscrollpane.min.js:19 b.fn.jScrollPane jquery.jscrollpane.min.js:720 jQuery.jQuery.extend.each jquery-1.4.4.min.js:648 jQuery.jQuery.fn.jQuery.each jquery-1.4.4.min.js:272 b.fn.jScrollPane jquery.jscrollpane.min.js:714 (anonymous function) KenmerkAdviseurArtikel.aspx:131 jQuery.jQuery.extend.ready jquery-1.4.4.min.js:447 jQuery.DOMContentLoaded jquery-1.4.4.min.js:875

Change History (2)

comment:1 Changed 8 years ago by danheberden

Owner: set to Cogito
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report. We require that all bug reports include a valid reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. This enables us to more easily investigate this issue further.

You can add jsScrollPane via the add resources area on the left of jsFiddle: http://jscrollpane.googlecode.com/svn-history/r95/trunk/dist/jScrollPane-1.2.3.js

If the plugin, though, is sending an object when it should be sending a string, that's going to require a bug-report with the plugin developer.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.