Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7863 closed bug (fixed)

Setting value of select based on ID containing brackets does not work

Reported by: faded1@… Owned by:
Priority: low Milestone: 1.5.1
Component: selector Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Example:

<select id="foo[bar]">
   <option>One</option>
   <option>Two</option>
   <option>Three</option>
</select>

<script type="text/javascript">
   $('#foo\\[bar\\]').val('Three'); // Does nothing in Jquery 1.4.4
</script>

Change History (4)

comment:1 Changed 9 years ago by ajpiano

Resolution: fixed
Status: newclosed

This issue has already been fixed. I know because i spent an hour the other day triaging this exact same issue with someone who found it on IRC!

https://github.com/jeresig/sizzle/commit/786ee06119c6d040d05817545e074fbdfb0d452d

You can use the latest GIT version on jsFiddle to confirm that the behaviour is fixed.

comment:2 Changed 9 years ago by ajpiano

#7889 is a duplicate of this ticket.

comment:3 Changed 9 years ago by jitter

Duplicate of #7533

comment:4 Changed 8 years ago by john

Component: unfiledselector
Milestone: 1.61.5.1
Priority: undecidedlow
Note: See TracTickets for help on using tickets.