Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7836 closed bug (invalid)

jquery attempts (improperly) to get ownerDocument of window.document

Reported by: anian6@… Owned by: anian6@…
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

I ran into this error when my code (accidentally) attempted initializing a jquery ui 1.8.6 autocomplete field from one Document to another, e.g.:

window.frames[frameName].func_that_initializes_autocomplete

I run across this error:

elem.ownerDocument is null at jquery-1.4.4.js:5481

After closer inspection, 'elem' within the code at 5481 references a Document, which of course has no owner Document. The Document referenced is the one that _instigated_ the function call, not the Document _containing_ the function call. I realize that this might be next to impossible to reproduce, but I thought I'd mention it in case it could be helpful.

jquery-1.4.4.js:5481

if ( !(defaultView = elem.ownerDocument.defaultView) ) {

return undefined;

}

Change History (3)

comment:1 Changed 9 years ago by anonymous

EDIT: The Document referenced is the Document containing func_that_initializes_autocomplete, not the instigating Document like I said before.

comment:2 Changed 9 years ago by dmethvin

Owner: set to anian6@…
Status: newpending

Can you put together a simple test case? However, from your description so far it sounds like this was due to a programming error in calling jQuery.

comment:3 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.