Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7829 closed bug (duplicate)

if id includes char DOT the size() will be wrong in IE7

Reported by: zhengxianquan@… Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Example html:

span id="hotel.query.keyword"
span id="hotel_query_keyword"

Example Code:

var id = "span#hotel\\\.query\\\.keyword";
alert($(id).size()); //'''is 1 in FF but 0 in my IE7'''
id = "span#hotel_query_keyword";
alert($(id).size()); //is 1 both in FF and IE

In firefox 3.6.13, every thing is OK.
In IE7, the first result will be different to FF.

Change History (5)

comment:1 Changed 9 years ago by ajpiano

Resolution: duplicate
Status: newclosed

Whatever happened to people actually searching to see if an issue exists ...?

comment:2 Changed 9 years ago by ajpiano

Duplicate of #7533.

comment:3 Changed 9 years ago by anonymous

It's not the same.

Please take a look to: http://jsfiddle.net/QYUPQ/1/

comment:4 Changed 9 years ago by snover

That link provides absolutely no evidence to suggest that this bug is not exactly the same as #7533. Furthermore, it’s invalid—you can’t have two elements with the same ID.

comment:5 Changed 9 years ago by dmethvin

Your test case is invalid. There are two elements with the same id. That is not allowed.

This attribute assigns a name to an element. This name must be unique in a document. http://www.w3.org/TR/html4/struct/global.html#h-7.5.2

Note: See TracTickets for help on using tickets.