Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7822 closed bug (invalid)

jQuery Mobile dropping stylesheets

Reported by: dahnniel.s@… Owned by: dahnniel.s@…
Priority: low Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by jitter)

Hello.

  1. The version(s) of jQuery affected

Newest jQuery & jQuery mobile (v.1.4.4 & v1.0a2)

  1. The browser (or browsers) that you are able to reproduce the bug in, including version numbers

Mozilla Firefox and Safari, only tried with them.

  1. The operating system (or operating systems) you experienced the bug on.

Windows & Mac

  1. Step-by-step instructions on how to reproduce the issue, including any required system configuration changes

Provide a form on page.html that has an action to itself (page.html), on submit it will validate and on correct user validating, it will redirect the user to the "protected" file myfile.html, when this happens it will drop the CSS styles.

  1. A description of what you expect to happen, and what actually happens

It to actually use the css.

  1. A link to a reduced, working demo/test case that will never move (jsFiddle is good for this)

Live example: http://www.djs-gaming.com/sms/2 Username: daniell password: daniell

  1. Information on other jQuery versions tested, including whether or not the issue is reproducible there

On the previous jQuerymobile version, I did not encounter this error.

  1. Information on other browsers where the issue does not occur

-

  1. References to the URL of a web server mentioned in your ticket (if any) in the case of a bug involving Ajax or server-side requests which are needed to fully evaluate the issue experienced.

PHP are used to validate the user, and then to redirect (Header(Location:)), and to output some data.

Appreciating any help, because I believe that this is not an error made by me. If so, I appologize.

Change History (4)

comment:1 Changed 9 years ago by Rick Waldron

Owner: set to dahnniel.s@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, test against the latest jQuery release and the jQuery 0 GIT version to ensure the issue still exists. Be Excellent to eachother!

comment:2 Changed 9 years ago by jitter

Description: modified (diff)

@rwaldron
Shouldn't this be filed on the jQuery Mobile bug tracker or do we accept jQuery Mobile bugs here also?

@dahnniel
Could this be related to the fact that the url after logging in is [...]/auth.php#auth.php but the form action points to [...]/biljett.php?

comment:3 in reply to:  2 Changed 9 years ago by anonymous

Replying to jitter:

@rwaldron
Shouldn't this be filed on the jQuery Mobile bug tracker or do we accept jQuery Mobile bugs here also?

@dahnniel
Could this be related to the fact that the url after logging in is [...]/auth.php#auth.php but the form action points to [...]/biljett.php?

If so, I'm sorry, I thought it was okay here aswell.

#2 Well, the form should point to auth.php, since that is the file which validates the login, if it gets validates as true, it sends a Header location: which moves the location to board.php, this is where it all goes wrong. Seems to have fixed it? Anyone mind trying? $(document).bind("mobileinit", function () {

$.extend($.mobile, { ajaxFormsEnabled: false });

});

comment:4 Changed 9 years ago by addyosmani

Priority: undecidedlow
Resolution: invalid
Status: pendingclosed

Thanks for taking the time to submit a detailed report on your bug. As rwaldron already mentions jQuery Mobile bugs should be posted to the jQuery Mobile bug tracker as they will be able to assist you further with this. Please re-submit your bug ticket there along with any further comments you feel would help them above.

Note: See TracTickets for help on using tickets.