Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7820 closed bug (duplicate)

jQuery find by ID fails when ID contains dots / "." / periods

Reported by: jquerybugs@… Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery does not find the ID "foo.bar" whereas document.getElementById() does. This is a major bug because it makes jQuery incompatible with existing sites/frameworks/libraries (like the one I am trying to minimally retrofit over jQuery).

Change History (2)

comment:1 Changed 8 years ago by ajpiano

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by ajpiano

Duplicate of #7533.

Note: See TracTickets for help on using tickets.