Bug Tracker

Opened 15 years ago

Closed 15 years ago

Last modified 10 years ago

#782 closed bug (invalid)

$('body').append(html) breaking within a plugin

Reported by: [email protected] Owned by:
Priority: major Milestone:
Component: core Version:
Keywords: Cc:
Blocked by: Blocking:

Description

I can't replicate this using different code (i.e. writing a different type of plugin), but a plugin I've written attaches a hidden div to the body tag, but fails with the new jQuery version.

Here is an example URL with the problem (tested in Safari + Firefox on Mac):

http://leftlogic.com/tests/text_grow.html

And the plugin:

http://leftlogic.com/jquery/textgrow.js

Breaks on 'var c = jQuery('body').append(html);'

Let me know if there is anything I can do or if more info is needed.

Thanks.

Change History (2)

comment:1 Changed 15 years ago by [email protected]

Sorry - didn't mean to leave it as major - I doubt if it's major!

comment:2 Changed 15 years ago by brandon

Resolution: invalid
Status: newclosed

Appending to body works fine. The actual error is caused by the leading underscore in the ID you are adding the div you are appending to the body. If you just remove the leading underscore, this will solve the error.

Feel free to reopen if you come across any other issues.

Note: See TracTickets for help on using tickets.