Bug Tracker

Opened 8 years ago

Closed 8 years ago

#7811 closed bug (worksforme)

populating hidden form fields in IE6

Reported by: colm.mcbarron@… Owned by: colm.mcbarron@…
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hi there,

I've discovered what I believe is a jQuery bug.

On one of our pages we inject HTML which includes some hidden form elements (type=hidden). These are then populated from another field on the page.

When I try to locate these form fields with a standard selector $('#myform-wrapper #hidden_field1') they come up as 'undefined' in IE6, but work just fine in other browsers. I've put a work around in place by doing a loop as follows

$.each($('#myform-wrapper input:hidden'), function(){

if ($(this).attr('id') == 'myid') {

do my stuff.

} });

This is obviously not ideal, the selector should really work here.

Change History (2)

comment:1 Changed 8 years ago by jitter

Owner: set to colm.mcbarron@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.


How to report bugs

comment:2 Changed 8 years ago by Rick Waldron

Resolution: worksforme
Status: pendingclosed

Following your use case, I cannot reproduce a bug

http://jsfiddle.net/rwaldron/DLYJC/1/

Note: See TracTickets for help on using tickets.