Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7807 closed bug (duplicate)

BUG - selector with context in Jquery 1.4.4

Reported by: raziel057 Owned by:
Priority: high Milestone: 1.5
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

There is a problem when creating a selector with a context (2nd parameter) which contains an id attribute with a dot or space.

See the following case: http://jsfiddle.net/pWzPu/4/

It works with Jquery 1.4.3 but not in 1.4.4.

Change History (4)

comment:1 Changed 9 years ago by jitter

Component: unfiledselector
Milestone: 1.next1.4.5
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report. This is a known bug an has been reported numerous times already. Please consider following the procedure described in How to report bugs then you should have found one of the duplicate reports and you would also have found that this is already fixed in the WIP version. test case with jQuery WIP version.

Btw. the id of the second tr in your test case is invalid, as id's can't contain spaces (HTML 5: The id attribute)

comment:2 Changed 9 years ago by jitter

Duplicate of #7533.

comment:3 Changed 9 years ago by john

Version: 1.4.41.5

There wasn't a 1.4.5 release, was actually 1.5.

comment:4 Changed 9 years ago by john

Milestone: 1.4.51.5

There was no 1.4.5 release, was actually 1.5.

Note: See TracTickets for help on using tickets.