Bug Tracker

Opened 8 years ago

Closed 8 years ago

#7798 closed bug (invalid)

Problem with .add and .fadeout() chainning methods.

Reported by: migueleliasweb@… Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

When channing with multiple .add() methods and a single .fadeout(), the callback seems to the called the number of adds used in the chain.

My conclusion was the alert was called 4 times.. exact number of selectors in the chain.

Ps: sry my bad english.

Thanks

Change History (1)

comment:1 Changed 8 years ago by ajpiano

Resolution: invalid
Status: newclosed

This is not a bug with .add(). When you call *any* jQuery animation on more than one element, the callback is fired for each element in the collection, not only once. This is true whether the elements were part of the initial selection, added with .add()...or any other way they could have gotten into the set.

If you have a support question (like, how do I only get the callback to fire when *all the animations are done*, for instance) please visit the jQuery forum (http://forum.jquery.com or #jquery IRC channel on freenode.

Note: See TracTickets for help on using tickets.