Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7766 closed bug (duplicate)

Change Event execute twice in IE8/IE7

Reported by: seeds Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Sample Source

<html>
 <head>
  <script type="text/javascript" src="js/jquery-1.4.4.js"></script>
  <script type="text/javascript">
$(document).ready(function() {
$('#a01').live('change', function() {
/// $('#a01').change(function() {
 var v = $(this).val();
 $('#a02').val(v);
 $(this).val('xxx'); // not happen change event in FF,Chrome
});
});
  </script>
 </head>
  <body>
    <input id="a01" type="text" name="a01">
    <input id="a02" type="text" name="a02">
  </body>
</html>

input "zzz" to #a01.

  • results(FireFox,Chrome): #a01 = xxx, #a02 = zzz
  • results(IE8,IE7): #a01 = xxx, #a02 = xxx

Change History (6)

comment:1 Changed 9 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Rick Waldron

Duplicate of #5997.

comment:3 in reply to:  2 Changed 8 years ago by anonymous

Replying to rwaldron:

Duplicate of #5997.

I do not think this is a duplicate of #5997.

comment:4 Changed 8 years ago by seeds

http://jsfiddle.net/d8kQh/1/

It seems to be different from #5997. jQuery 1.5.1 still has this bug.

comment:5 Changed 8 years ago by seeds

http://jsfiddle.net/d8kQh/2/

bubbled change event happend both .live and .change.

comment:6 Changed 8 years ago by anonymous

It seemed to be improved in jQuery 1.7.

Note: See TracTickets for help on using tickets.