Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7756 closed bug (duplicate)

mouseover and mouseout events are not fired within live in 1.4.4

Reported by: amit.sites@… Owned by:
Priority: high Milestone: 1.6
Component: event Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

I just upgraded from jQuery 1.4.2 to 1.4.4. The following code got broken: $('#element').live('hover',function(ev) {

if (ev.type =='mouseover') {

Something

} else if (ev.type == 'mouseout') {

Something else

}

}

If I do debug printing on ev.type, I receive only mouseenter and mouseleave messages. Is this a bug or an enhancement? Tried to look for it in the release notes but couldn't find such a behavior change.

Many thanks!

Change History (4)

comment:1 Changed 9 years ago by rtpmatt

I believe hover binds events to mouseenter/mouseleave not mouseover/mouseout.

see: http://api.jquery.com/hover/

It does seem to work in 1.4.2 though

http://jsfiddle.net/uUq3B/

Last edited 9 years ago by rtpmatt (previous) (diff)

comment:2 Changed 9 years ago by Rick Waldron

Component: unfiledevent
Priority: undecidedhigh
Status: newopen

Confirmed;

http://jsfiddle.net/rwaldron/uUq3B/2/

<= 1.4.2 : over/out

1.4.3 : enter/leave

comment:3 Changed 9 years ago by Rick Waldron

Resolution: duplicate
Status: openclosed

comment:4 Changed 9 years ago by Rick Waldron

Duplicate of #6514.

Note: See TracTickets for help on using tickets.