Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7713 closed bug (worksforme)

.template parameters not evaluated in firefox

Reported by: 1lukas1@… Owned by: 1lukas1@…
Priority: undecided Milestone: 1.6
Component: templates Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Take an example part of the template <a href="${www}" class='link' rel='external'>${www}</a>

In FF 3.6.12 it renders as (href part is not replaced with actual link)

<a href="$%7Bwww%7D" class='link' rel='external'>some.site.com</a>

While in Chrome it works OK

<a href="some.site.com" class='link' rel='external'>some.site.com</a>

However in similar situation (where template var is tag parameter) works OK in both browsers:

<input name='title' id='title' value='${title}'/>

<input name='title' id='title' value='Some title'/>

Change History (6)

comment:1 Changed 8 years ago by anonymous

p.s. happens on Fedora14 x86

comment:2 Changed 8 years ago by jitter

Component: unfiledtemplates
Owner: set to 1lukas1@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.

comment:3 Changed 8 years ago by BorisMoore

Is the template declared in a script block? If the template is being taken as innerHTML from a HTML element (e.g. div) not a script block, then there can be issues for anchor tags due to different browser serialization behavior. If so, can you try again with the template wrapped in a script block, per the best practice... Thanks...

comment:4 Changed 8 years ago by Rick Waldron

Resolution: worksforme
Status: pendingclosed

Following the documentation, I can confirm that this is not a bug in jQuery Templates

http://jsfiddle.net/rwaldron/yssDf/

comment:6 Changed 8 years ago by dmitryklerik@…

i have this bug on firefox 3.6.17 on Ubuntu 10.04

Template declared as javascript variable

comment:7 Changed 8 years ago by BorisMoore

Bugs for jQuery templates should be declared here: https://github.com/jquery/jquery-tmpl/issues

The issue above is not bug. See the following related issues: https://github.com/jquery/jquery-tmpl/issues/5 https://github.com/jquery/jquery-tmpl/pull/31

Note: See TracTickets for help on using tickets.