Bug Tracker

Opened 8 years ago

Closed 8 years ago

#7707 closed bug (invalid)

Inside an ajax event dollar sign operator does not return xmlDocument tag

Reported by: karabulutalper@… Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by jitter)

Inside an ajax event; i.e.

$.ajax({  
    type: "POST",
    contentType: "application/xml",
    url: "getUrsip.irpt",
    data: "ursip=" + siparis.value,
    complete: function( transport ) {
        xml = transport.responseXML;
        $( "kunnr" ).value = $( "KUNNR", xml );
    }
);

$("KUNNR", xml); returns null parameter even xml has a xml formated document..

Change History (2)

comment:1 Changed 8 years ago by jitter

Description: modified (diff)
Summary: inside a ajax event dolar sign operator does not returns xmlDocument tagInside an ajax event dollar sign operator does not return xmlDocument tag

fixed formatting

comment:2 Changed 8 years ago by jitter

Resolution: invalid
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report.

We require that all bug reports include a valid reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net.
As such a test case is missing from the report I made one based on your description. This live test case works for me like expected.

After checking your report and making a test case I think that there is no bug and that your problem is most likely caused by something else. I close this ticket, but feel free to report back with a valid reduced test case showing the bug and demand the reopening of this ticket

A few notes:

  • in the code you pasted a curly closing bracket is missing
  • you set contentType to application/xml but data is a non XML string
  • are you sure the XML returned by the server is valid XML
  • did you try using the error callback to check if there is and/or what the error is

How to report bugs

Note: See TracTickets for help on using tickets.