Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7682 closed bug (duplicate)

Unexpected behavior of find function

Reported by: serg@… Owned by:
Priority: low Milestone: 1.5
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

From console:

$(".no-sdcard:visible ~ .no-sdcard").length
=>3
$(".no-sdcard:visible").find("~ .no-sdcard").length
=>0

This works on 1.4.2. From 1.4.3 it's broken

Change History (5)

comment:1 Changed 8 years ago by Serg Podtynnyi <serg@…>

http://jsfiddle.net/633jw/ test with 1.4.2, 1.4.3, 1.4.4

comment:2 Changed 8 years ago by jitter

Component: unfiledselector
Milestone: 1.next1.4.5
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a test case!

After checking your report and test case I came to the conclusion that this bug was already reported. Thus I close this ticket as duplicate. Please check the below mentioned ticket for progress on this issue.

comment:3 Changed 8 years ago by jitter

Duplicate of #7452.

comment:4 Changed 8 years ago by john

Version: 1.4.41.5

There wasn't a 1.4.5 release, was actually 1.5.

comment:5 Changed 8 years ago by john

Milestone: 1.4.51.5

There was no 1.4.5 release, was actually 1.5.

Note: See TracTickets for help on using tickets.