Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7680 closed bug (duplicate)

.find is not working correctly when called on element selected with a period in selector

Reported by: education-rf@… Owned by:
Priority: high Milestone: 1.5
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

I have a div with id="my.div". I am selecting it as $('my\\.div' ) and it is working for me.

When I try to find children of the div with .find('tagName'), it doesn't find anything.

var parent = $('#my\\.div');
  
    console.log( "parent " + parent.length + '\n' +
          ".find('option') " + parent.find('div').length + '\n' +
          ".children('option') " + parent.children('div').length + '\n');

This will output:

parent 1 
.find('option') 0 
.children('option') 1 

You can see example here http://jsbin.com/ukepa3/12

NB: in 1.4.2 it works as expected

Change History (4)

comment:1 Changed 9 years ago by jitter

Component: unfiledselector
Milestone: 1.next1.4.5
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by jitter

Duplicate of #7533.

comment:3 Changed 8 years ago by john

Version: 1.4.41.5

There wasn't a 1.4.5 release, was actually 1.5.

comment:4 Changed 8 years ago by john

Milestone: 1.4.51.5

There was no 1.4.5 release, was actually 1.5.

Note: See TracTickets for help on using tickets.