Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#7674 closed bug (duplicate)

Onchange event fires twice

Reported by: jeff@… Owned by:
Priority: low Milestone: 1.5
Component: event Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

When I have, for exemple, a SELECT element with hard-coded onchange (inside the HTML tag), and if I add an additional function to run on change event (with the JQuery .change(function(){}) method), then the hard-coded function is run twice ...

Change History (5)

comment:1 Changed 8 years ago by jitter

Resolution: invalid
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report!

I can't reproduce what you are describing with this test case. So I guess there is some other problem in your code.

If you think this ticket was closed incorrectly, feel free to report back and submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net.


How to report bugs

comment:2 Changed 8 years ago by anonymous

I'm sorry, I should have specified that the bug occurs on Internet Explorer 8.

I used your test case and the bug is reproduced !!!

By the way, the HTML field on jsFiddle can not be edited on IE8 ...

comment:3 Changed 8 years ago by jitter

Resolution: invalid
Status: closedreopened

comment:4 Changed 8 years ago by jitter

Component: unfiledevent
Milestone: 1.next1.5
Priority: undecidedlow
Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 8 years ago by jitter

Duplicate of #6593.

Note: See TracTickets for help on using tickets.