Bug Tracker

Opened 8 years ago

Closed 8 years ago

#7662 closed bug (invalid)

$('body').children() puts java applet in incosistent state - opera only

Reported by: zeljko Owned by: zeljko
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery: 1.4.4
Browser: Opera 10.63

Problem:

After performing selection with $('body').children(), call to applet method (from javascript) fails with following message: "message: java.lang.NoSuchFieldException: nextSibling".

It appears that .children() method uses sibling() method to move through element siblings, in that method there is a loop: "for ( ; n; n = n.nextSibling )", my guess is that call to n.nextSibling on applet element will try to invoke applet method "nextSibling". It will not fail, but next call to applet method will fail.

This is an issue only in Opera, it seems that it doesn't affect other browsers.

Change History (4)

comment:1 Changed 8 years ago by jitter

Owner: set to zeljko
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report!

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.


How to report bugs

Last edited 8 years ago by jitter (previous) (diff)

comment:2 Changed 8 years ago by zeljko

Status: pendingnew

It appears to be the problem with opera. It appears that when you call method that doesn't exist on applet opera will not display error message right now but will throw exception on next valid method call.

comment:3 Changed 8 years ago by jitter

Status: newpending

As stated in my first comment please provide a working test case so that we can investigate this issue, not just an error description.

Also please add information if you are using the <applet> or the <object> tag. If you use the former please check if this still happens if you switch to the object tag as the applet tag is deprecated anyway.

Last edited 8 years ago by jitter (previous) (diff)

comment:4 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.