Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7658 closed bug (duplicate)

after() throws nonsense error if called on an empty selection

Reported by: matteosistisette Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Consider this expression:

$("#nonexistent").after(",");

If there is at least one element with id="nonexistent", then this expression adds a comma after it.

If there is no such element, it throws the following error: "Error: uncaught exception: Syntax error, unrecognized expression: ,"

I'm not sure whether it should throw any error at all (i think it shouldn't, should just do nothing), but _certainly_ this is not the error that should be thrown. The expression "," is perfectly valid, as it is an html string; the proof is that when the selection is not empty, it works.

Change History (2)

comment:1 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by snover

Duplicate of #7623.

Note: See TracTickets for help on using tickets.