Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7646 closed bug (worksforme)

IntegrityError: (1062, "Duplicate entry 'warpr-1-name' for key 'PRIMARY'")

Reported by: anonymous Owned by:
Priority: low Milestone: 1.6
Component: web Version: 1.4.4
Keywords: Cc: snover
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /register, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'6977d4f754bd0ec5d6d0e555',
 'action': u'create',
 'email': u'kuno@frob.nl',
 'name': u'Kuno Woudt',
 'password': u'(removed)',
 'password_confirm': u'(removed)',
 'user': u'warpr'}

User agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.6/dist-packages/TracAccountManager-0.2.1dev_r9276-py2.6.egg/acct_mgr/web_ui.py", line 394, in process_request
    _create_user(req, self.env)
  File "/usr/local/lib/python2.6/dist-packages/TracAccountManager-0.2.1dev_r9276-py2.6.egg/acct_mgr/web_ui.py", line 141, in _create_user
    (user, key, value))
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/pymodules/python2.6/MySQLdb/cursors.py", line 166, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib/pymodules/python2.6/MySQLdb/connections.py", line 35, in defaulterrorhandler
    raise errorclass, errorvalue
IntegrityError: (1062, "Duplicate entry 'warpr-1-name' for key 'PRIMARY'")

Change History (2)

comment:1 Changed 8 years ago by addyosmani

Cc: snover added
Resolution: worksforme
Status: newclosed

Thank you for submitting a bug to the jQuery Bug Tracker!

I've just re-tested our Trac registration with Firefox 3.6.12 and everything (POST requests included) appear to be working fine without any issues. That said we will have a member of the infrastructure team investigate the issue reported just to make sure that everything is working without issue.

comment:2 Changed 8 years ago by snover

Component: unfiledweb
Priority: undecidedlow

This is almost certainly a race condition in the AccountManager module caused by the user clicking the submit button twice in rapid succession. It has been reported upstream at TracHacks #8217.

Note: See TracTickets for help on using tickets.