Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7622 closed bug (worksforme)

FF 4b7: $(form).submit() does not work

Reported by: anonymous Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by jitter)

$('#id').submit() does not work with Firefox 4.0 beta 7, if the submit-handler was assigned later than $.ready()

Here is a testcase: http://jsfiddle.net/3vkpk/7/

Thanks Markus

Change History (9)

comment:1 Changed 9 years ago by jitter

Resolution: worksforme
Status: newclosed

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a testcase! I tried your test case in FF 4.0 beta 7 on WinXP and it worked as expected.

If you feel this ticket was closed incorrectly and the problem still persists for you, feel free to report back with a reproducible test case and request the reopening of this issue.

comment:2 Changed 9 years ago by jitter

Description: modified (diff)

comment:3 Changed 9 years ago by anonymous

No, it does not work. You will fire the submit, not the "alert()"

comment:4 Changed 9 years ago by Rick Waldron

worksforme +1

comment:5 Changed 9 years ago by jitter

For me it shows the alert but doesn't execute the actual submit as preventDefault gets called and is working too.

Please provide information on what platform you are on? And are you sure about the browser version being FF 4.0b7? Can you copy-paste the last two lines of information from "Help -> About Firefox".

Did you try with a clean install of FF?

comment:6 Changed 9 years ago by anonymous

Hello,

I got two complains, that submiting won't work with FF 4b7. After an update I could see the same issue. This testcase works in any browser but FF 4b7: http://doppelbauer.name/submit.php

Here is a screenshot of Help->About: http://doppelbauer.name/submit.jpg

Markus

comment:7 Changed 9 years ago by anonymous

Stop. Sorry, my fault. I must re-write the testcase.

comment:8 in reply to:  7 Changed 9 years ago by jitter

Replying to anonymous:

Stop. Sorry, my fault. I must re-write the testcase.

Did you already? The test site on http://doppelbauer.name/submit.php works for me in FF 4b7. alert is shown but form not submitted. (Please add information on the platform you are on WinXP/Vista/7, Linux(Ubuntu,etc.)

comment:9 Changed 9 years ago by anonymous

Just a note -- FF4b7 is beta software and b8 is just around the corner.

Note: See TracTickets for help on using tickets.