Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7620 closed bug (duplicate)

issue noticed with $("*",divElement) execution

Reported by: pratik.shah76@… Owned by: pratik.shah76@…
Priority: high Milestone: 1.5
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

Issue is in executing $(“*”,div) method. It is not traversing each inner domain elements of div if div has certain pattern of Id.

Visit http://jsbin.com/equge3 link for the test application I created.

You can notice that ‘spouse’ dom elements are not traversing if div has id with pattern “FE12[FE23]” but parent dom elements worked fine if div has id with pattern “FE12[0]” It means it is expecting numeric characters inside brackets in current release of jQuery 1.4.4.

Above example works fine in jQuery 1.4.2.

Change History (7)

comment:1 Changed 9 years ago by Rick Waldron

Owner: set to pratik.shah76@…
Status: newpending

Can you please reduce this to a more simplified test case? http://jsfiddle.net/

comment:2 Changed 9 years ago by pratik.shah76@…

Status: pendingnew

Thank You! for quick response

I created test case using jsfiddle

http://jsfiddle.net/5Jr8R/2/

In my test case two separate div elements and want to modify id of each div.

Here are logical steps I am following:

  • select each div
  • modify div id with new one by appending [FEIEI2C90] for the first one and [0] for the second one
  • traverse each element to modify each inner element

comment:3 Changed 9 years ago by jitter

Blocked by: 7533 added
Component: unfiledselector
Milestone: 1.51.4.5
Priority: undecidedhigh
Status: newopen

Thanks for taking the time to contribute to the jQuery project by writing a bug report and providing a testcase!

reduced test case

jQuery has sometimes issues when the id attribute contains meta characters. Here it is triggered as jQuery internally uses the present id attribute to speed up the search. Check on #7533 which (once fixed) should also fix this bug.

comment:4 Changed 9 years ago by jitter

Blocked by: 7533 removed
Resolution: duplicate
Status: openclosed

comment:5 Changed 9 years ago by jitter

Duplicate of #7533.

comment:6 Changed 9 years ago by john

Version: 1.4.41.5

There wasn't a 1.4.5 release, was actually 1.5.

comment:7 Changed 9 years ago by john

Milestone: 1.4.51.5

There was no 1.4.5 release, was actually 1.5.

Note: See TracTickets for help on using tickets.