Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7619 closed bug (duplicate)

selectors broken if id contains period

Reported by: mschaefers@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

In the following example the console output is supposed to be "1", but as long as the id attribute contains a period, the find selector does not work.

jQuery 1.4.3 works as expected.

<html>
<head>
<script type="text/javascript"
	src="https://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js"></script>
</head>

<body>

<script type="text/javascript">
$(document).ready(function() {
    console.info($('div').find('input').length)
});
</script>

<div id="test.id"><input type="checkbox"></div>
</body>
</html>

Change History (2)

comment:1 Changed 9 years ago by addyosmani

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by addyosmani

Duplicate of #7533.

Note: See TracTickets for help on using tickets.