Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#7586 closed bug (duplicate)

jQuery.ajax removes script whose type is not text/javascript from html response

Reported by: softlion Owned by:
Priority: high Milestone: 1.5
Component: manipulation Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

When using jQuery.ajax to retreive html, if this html contains a script tag, the tag is removed from the html when it is inserted in the DOM.

This should not happen is the type of the script is not "text/javascript".

Example: FBML scripts from facebook (script type="text/fbml")

Change History (6)

comment:1 Changed 10 years ago by jitter

Owner: set to softlion
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report!

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further as some quick tests show this working for me test case.


How to report bugs

Last edited 10 years ago by jitter (previous) (diff)

comment:2 Changed 10 years ago by jitter

Owner: softlion deleted
Status: pendingnew

comment:3 Changed 10 years ago by jitter

Resolution: worksforme
Status: newclosed

No test case was provided. Closing. Feel free to reopen with a reproducible test case.

comment:4 Changed 9 years ago by jdsharp

Resolution: worksforme
Status: closedreopened

Test case created: http://jsfiddle.net/E5Ygp/

comment:5 Changed 9 years ago by jitter

Component: unfiledmanipulation
Priority: undecidedhigh
Resolution: duplicate
Status: reopenedclosed

comment:6 Changed 9 years ago by jitter

Duplicate of #6180.

Note: See TracTickets for help on using tickets.