Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7564 closed bug (duplicate)

Chrome and Safari seem to strip double quotes van result form .css()

Reported by: wj.vandenbrink@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Using .css() gives different results depending on browser, namely minimally one difference between Firefox, IE, Opera on the one hand and Chrome and Safari on the other, specifically: double quotes are absent in the Crhome-result while present in the Fireforx-result:

backgroundurlnow = $('div.backgroundholder').css('background-image');////want to know background image
alert(backgroundurlnow);

gives in the alertbox:

url("http://localhost--etc--.jpg")

with Firefox, IE and Opera, but

url(http://localhost--etc--.jpg)

with Crhome and Safary

(jquery-1.4.4.min.js)

Change History (2)

comment:1 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by snover

Duplicate of #3923.

Note: See TracTickets for help on using tickets.