Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7545 closed bug (worksforme)

Hide/show on a table row fails for Firefox in certain cases

Reported by: Peter Crabtree <peter.crabtree@…> Owned by: Peter Crabtree <peter.crabtree@…>
Priority: low Milestone:
Component: effects Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hiding a row, attaching it to the DOM, then showing it causes the display to be set to "block" for Firefox (which is bad, since it then causes the row to show in the first column only).

(Tested on Firefox 3.6.10)

http://jsfiddle.net/Nqfa4/2/

Change History (5)

comment:1 Changed 9 years ago by Rick Waldron

Component: unfiledeffects
Milestone: 1.5
Owner: set to Peter Crabtree <peter.crabtree@…>
Priority: undecidedlow
Status: newpending

Please take a look at this:

http://jsfiddle.net/rwaldron/Nqfa4/5/

Can you confirm this is the behavior you were expecting?

comment:2 in reply to:  1 ; Changed 9 years ago by Peter Crabtree <peter.crabtree@…>

Status: pendingnew

Replying to rwaldron:

http://jsfiddle.net/rwaldron/Nqfa4/5/

Can you confirm this is the behavior you were expecting?

In Firefox 3.6.10, that adds two rows, unless I have FireBug open, in which case it adds one. :-/

The intended behavior is to add a hidden row, and then show it (in a real-world application, the showing part would happen later).

comment:3 in reply to:  2 Changed 9 years ago by jitter

Status: newpending

Replying to Peter Crabtree <peter.crabtree@…>:

Replying to rwaldron:

http://jsfiddle.net/rwaldron/Nqfa4/5/

Can you confirm this is the behavior you were expecting?

In Firefox 3.6.10, that adds two rows, unless I have FireBug open, in which case it adds one. :-/

The intended behavior is to add a hidden row, and then show it (in a real-world application, the showing part would happen later).

That's only because console is undefined and the js is run twice. Try http://jsfiddle.net/Nqfa4/6/

Can you can confirm that's the behavior you want?

comment:4 Changed 9 years ago by Peter Crabtree <peter.crabtree@…>

Status: pendingnew

That's the behavior I want/expect; yes.

comment:5 Changed 9 years ago by jitter

Resolution: worksforme
Status: newclosed

Ok then. http://jsfiddle.net/jitter/Nqfa4/7/

Thanks for taking the time to contribute to the jQuery project.

If you feel this ticket was incorrectly closed feel free to report back and reopen the issue.

Note: See TracTickets for help on using tickets.