Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7528 closed bug (wontfix)

$("> a, > p") may not work correctly

Reported by: john Owned by: john
Priority: low Milestone: 1.next
Component: selector Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by timmywil)

Need to follow-up on this comment.

Change History (16)

comment:1 Changed 9 years ago by john

Component: unfiledselector
Owner: set to john
Status: newassigned

Specifically the second selector won't work correctly - we need to parse that properly, presumably. A QUnit test case would be good here (applied against Sizzle).

comment:2 Changed 9 years ago by john

Keywords: needstest added
Milestone: 1.51.4.5
Priority: undecidedlow

comment:3 Changed 9 years ago by jitter

live test case shows that this is indeed failing.

comment:4 Changed 9 years ago by john

Priority: lowblocker

comment:5 Changed 9 years ago by timmywil

Keywords: needstest removed

comment:6 Changed 9 years ago by timmywil

#6279 is a duplicate of this ticket.

comment:7 Changed 9 years ago by john

Description: modified (diff)

comment:8 Changed 9 years ago by john

Keywords: 1.7-discuss added

Nominating ticket for 1.7 discussion.

comment:9 Changed 9 years ago by Rick Waldron

+0,

comment:10 Changed 9 years ago by jaubourg

+0,

comment:11 Changed 9 years ago by timmywil

Description: modified (diff)

comment:12 Changed 9 years ago by john

-1, Considering that we're likely deprecating leading > selectors anyway, this seems like a very low priority issue.

comment:13 Changed 9 years ago by scottgonzalez

+1, PLEASE PLEASE PLEASE don't deprecate selectors starting with >. This is extremely useful for building generic plugins that allow customizing which elements to work against.

comment:14 Changed 9 years ago by ajpiano

+0, I guess this depends on the outcome of the decision on leading > selectors...

comment:15 Changed 9 years ago by jzaefferer

+0

comment:16 Changed 9 years ago by Rick Waldron

Keywords: 1.7-discuss removed
Priority: blockerlow
Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.