Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7491 closed bug (invalid)

add click function error in IE8

Reported by: wangxing.pku@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

The original html source is: <img id="nextmusic" src="/static/pic/next.gif"/>

I use jquery to add function. $("#nextmusic").click(nextmusic);

I get the processed html by using the debug tool provide by MS and get: <img id="nextmusic" src="/static/pic/next.gif" complete="complete" jQuery1289576534211="2"/>

It works well on chrome.

Change History (1)

comment:1 Changed 9 years ago by ajpiano

Resolution: invalid
Status: newclosed

jQuery currently does add that crazy attribute to elements in IE to which it has bound events. It is an unfortunate side effect that we hope to eventually get rid of, but it is not a bug with .click().

Note: See TracTickets for help on using tickets.