Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7460 closed bug (duplicate)

Validate breaks on id="id" or name="id"

Reported by: finkel@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

If a form has ANY input element (even one that is not subject to validation) that has either its ID or NAME set to "id", then the error label is never reset on the fields that are subject to validation.

<p>
<label for="cemail">Email</label>
<input type="text" class="required email" id="cemail" name="email" value="" />
</p>

<!-- 
Because the following input element has its ID and/or NAME
set to "id", the error label for ALL elements, such as the one 
above, is not reset correctly when its contents transitions 
from an invalid to valid entry.  This is true even though the 
element is NOT subject to validation.
-->
<p>
<label for="mid">Message ID</label>
<input id="id" type="text" name="id" value="5" />
</p>


Change History (2)

comment:1 Changed 10 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by Rick Waldron

Duplicate of #7212.

Note: See TracTickets for help on using tickets.