Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7449 closed bug (worksforme)

element hidden external to DOM doesnt show (once appended)

Reported by: enideo Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.4rc
Keywords: Cc:
Blocked by: Blocking:

Description

When an element is created out of the DOM and it's hidden then it does not appear when simultaneously inserted into the DOM and faded in. This is the scenario where I found it, perhaps the simultaneous part / external to the DOM is not relevant. Bug occurs on my Ubuntu versions of Chrome (7.0.517) and Opera (10.63), but not Firefox. http://jsfiddle.net/B4ag5/3/

Not sure if this is a true bug as the scenario might not be a feature jQuery intends to support but it is a regression since 1.4.3. Could be related to bug #7331 which has been fixed -raised after my comment on GitHub: https://github.com/jquery/jquery/commit/6ab402dced3339d24ad007ecf3a6c3f5af3e7610#comments

Hope this helps with the release, Kev

PS someone else has written comment:3:ticket:7331 about the loss of the original display value (inline, block), could be related, not sure if a proper bug has been filed for that issue either so thought I'd mention it here

Change History (4)

comment:1 Changed 9 years ago by boushley

I think the issue has more to do with the fact that when you do hide while its not in the dom show or fadein or any of the above fail as show with this fiddle http://jsfiddle.net/boushley/B4ag5/6/ Even if its not done at the same time it still doesn't work. However if you use .css('display', ) it works as is shown in this http://jsfiddle.net/boushley/B4ag5/5/

So this is an issue with the fact that if you hide an element while it's not attached to the dom you can't show it once it is attached to the dom.

comment:2 Changed 9 years ago by boushley

Also of note, if you run all of these jsfiddle's against the newest version of jQuery (the GIT 0) on jsfiddle the issue is resolved.

comment:3 Changed 9 years ago by enideo

Oh yeah you're right it does work with the Git version, sorry I didn't check! Thanks for looking into it anyway..

comment:4 Changed 9 years ago by snover

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.