Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7439 closed bug (duplicate)

Links not visited in IE with ajax

Reported by: liechtypo Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

In jquery, when you dynamically create links in a page whose href points to the very same page, the links do not show as visited in IE. I tried to create a jsfiddle example, but it doesn't work because of the nature of the example. I am hosting the example here:

http://www.patrickliechty.com/dev/jquery-link-bug.html

It uses the bbq history library to handle updating the page without a page refresh.

This happens in IE 7 and 8

Change History (5)

comment:1 Changed 9 years ago by liechtypo

I need to add more explanation for the example. To reproduce, click page page 1 link 1. It will get rid of those links and create a new set. Click page 2 link 1. It will get rid of those links and create a new set or page. Click page 3 link 1 and it will take you back to page 1. Notice page 1 link 1 is not shown as visited. This only happens in IE 7 and 8. It works great in Firefox.

comment:2 Changed 9 years ago by snover

Resolution: invalid
Status: newclosed

Thanks for the report, but this is not a jQuery bug. The same behaviour can be demonstrated at this link which does not involve jQuery. Click the link, then refresh the page, and notice that IE “forgets” that it has been visited.

comment:3 Changed 9 years ago by Rick Waldron

Resolution: invalid
Status: closedreopened

comment:4 Changed 9 years ago by Rick Waldron

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 9 years ago by Rick Waldron

Duplicate of #7122.

Note: See TracTickets for help on using tickets.